TCPStart / TCPStartAll

Christie Widget Designer Version 6 - Q&A

Moderator: Moderator Group

Forum rules
When asking make sure to include the operating system and the revision of Widget Designer you are using.

TCPStart / TCPStartAll

Postby maccalder » Tue Jan 10, 2017 11:28 pm

I seem to be having issues with TCPStart and TCPStartAll - I have a stop/start toggle button. TCPStopAll works beautifully. At this point I have only programmed one TCP connection, but it drops the connection, all good. Toggle it so that it runs the script with TCPStartAll and I get the following in the debug window (Typed, not copied and pasted)

Code: Select all
2017-01-11 09:06:08 Command 'TcpStartAll' exception: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
 >Window1/Main/power/ClickScript
 > ...for Token "TcpStartAll" at 4/1


I am treating it exactly like TcpStopAll - so not passing it any parameters.

Since I only had one Tcp connection programmed so far, I also tried TcpStart(1) and get the same error (just with TcpStart instead of TcpStartAll)

The TCP connection is a client connection - I can manually start from connection manager with no dramas

Any assistance most welcome

Regards

-Mac

PC: Xeon E3-1225 @ 3.3GHz, 8gb RAM, Windows 10 Enterprise LTSB, WD6 Unlimited 4242-RC
WD PC: Xeon E3-1225 @ 3.3GHz, 8gb RAM, Windows 10 Enterprise LTSB, WD6 Unlimited 4242-RC
PB PC: Xeon E3-1220 @ 3.5GHz, 8gb RAM,Gigabyte GeForce GTX 1050 Ti OC 4G, Windows 10 Enterprise LTSB
maccalder
 
Posts: 11
Joined: Wed Nov 04, 2009 10:22 am
Location: Melbourne, Australia

Re: TCPStart / TCPStartAll

Postby Justyn Roy » Wed Jan 11, 2017 3:21 pm

This is a known issue that is been reported is being addressed.

Thank you,

Justyn
User avatar
Justyn Roy
 
Posts: 26
Joined: Tue Sep 27, 2016 1:26 am


Return to Widget Designer V6

Who is online

Users browsing this forum: No registered users and 3 guests