Web Browser Issues

Christie Widget Designer Version 6 - Q&A

Moderator: Moderator Group

Forum rules
When asking make sure to include the operating system and the revision of Widget Designer you are using.

Web Browser Issues

Postby pedro_benito » Mon Feb 13, 2017 10:38 am

Hello everybody,

I've been doing some testing with the new version of WD and the new web-browser, and i cannot connect through any wireless or cable device to the IP where WD is executing. At the beginning I thought about ports issues, but I tried with WD4.6 and it works perfectly with the same network configuration. I try to check in the online manual, but I don't find the solution. Could you help me out with this?


Thank you!
pedro_benito
 
Posts: 12
Joined: Mon May 07, 2012 6:54 pm

Re: Web Browser Issues

Postby Justyn Roy » Mon Feb 13, 2017 3:47 pm

What is the address you're entering?

The default in 4.7 is xxx.xxx.xxx.xxx:8080

The new default in 6, you don't need the port number, so just enter the IP address - unless you've changed what the default it (which is port 80).


Hope that helps!
User avatar
Justyn Roy
 
Posts: 40
Joined: Tue Sep 27, 2016 1:26 am

Re: Web Browser Issues

Postby pedro_benito » Mon Feb 13, 2017 4:01 pm

I haven't add any port. I can access through chrome to the UI of Widget Designer only from the computer where WD is executing, but when I try to access through my ipad, the server doesn't show nothing. Besides, with version 4.6 works perfectly.
pedro_benito
 
Posts: 12
Joined: Mon May 07, 2012 6:54 pm

Re: Web Browser Issues

Postby Thomas Mrozek » Mon Feb 13, 2017 5:44 pm

Hi,
there are some possibilities why the service is blocked. If you are using WD free edition and you are locally connected, this counts already for 1 connection and the WD free edition is not capable to use more.
If you are using a WD or unlimited Version (or unconnected free edition) and you opened already different WD it could happen that the port is already blocked. In this case please have a look at Edit > Web Server Settings. At the top of the dialog, you can see which ports are used right now. If it is port 80 for HTTP (which is the default value), all you would have to enter in your browser is the IP address. If any other port is used, you would have to specify so in the browser, e.g.: "192.168.1.56:30300" for HTTP port 30300.
Thomas Mrozek
Technical Support Engineer
User avatar
Thomas Mrozek
 
Posts: 63
Joined: Mon Apr 20, 2009 11:08 am

Re: Web Browser Issues

Postby pedro_benito » Tue Feb 14, 2017 11:12 am

Hi,

Thanks for your reply. It wasn't any problem with the ports or WD version (Im using PRO). It was a problem with windows firewall. It seams WD4.6 bypass correctly, but WD 6.0 doesn't.

It would that in next versions this could be fix.

Thanks.
pedro_benito
 
Posts: 12
Joined: Mon May 07, 2012 6:54 pm

Re: Web Browser Issues

Postby chrisr » Wed Feb 15, 2017 4:34 pm

I had this same issue. 4.7 worked flawlessly 6 was a pita.
Thank You

ChrisR
SurfacePro3 - 2GHz i5 - 4GB ram - Windows 10 Pro - WD Pro 4.7 Rev2500 and WD 6 Rev6322
Sager Laptop - Intel 2.4GHz i7 3630QM - 16GB ram - Windows 7 Pro Svc Pack1 - Offline Manager V5.1_Rev13378 & V6_Rev15101
chrisr
 
Posts: 117
Joined: Tue Jan 26, 2016 10:50 pm

Re: Web Browser Issues

Postby schoissi » Wed Apr 05, 2017 2:23 am

hi guys,

*/ part1...
i can run wd v6 rev. 4498 web server on local networks without any problems,
buttons work, scripts work, faders work...

when i connect from the internet, thru dyndns, i can access the page, see all controls, labels, buttons, etc.
but it doesn't influence anything when i, for example, change a fader or click a button.
( for testing, i currently only tried my iphone SE, with safari, running over tmobile lte, in the usa...)

first attempt failed at all, because of windows firewall, turned it off and it works (to get at least to view the widget designer page...).

in my router, i have setup dyndns, and portforward for port 80 and 30300.
fixed ip on the pc (and set fixed ip with mac binding in my router for this pc).

any ideas?
oh, windows 10 pro...

*/ end of part 1...

also,
on firefox on mac (latest firefox release, osx 10.11.6) i can't see css styles, for example reflection...
same mac, with safari, it works...

thx

edit on 5.4.2017:
aehem...
when settinp up dyndns and portforwarding correct, it actually works great :-)
for */ part 1 /*
you need to forward all needed ports, 80, 8080, 81 (i assume if your webserver runs alternatively on 30300, this one too...)

THX :-)
schoissi
 
Posts: 51
Joined: Thu Jan 01, 2009 9:48 pm
Location: Seattle, USA

Re: Web Browser Issues

Postby marcusgarfunkel » Wed May 31, 2017 6:18 pm

I am having the same issues with the Windows 10 Firewall blocking access to the WD Web Server. Accessing the server from localhost works, and from a remote host whilst the firewall is off. When the firewall is on, the web server cannot be reached from a remote host. Can this be addressed? Maybe a new rule must be added?

Sincerely,
Marcus
marcusgarfunkel
 
Posts: 2
Joined: Wed Apr 01, 2015 4:24 pm

Re: Web Browser Issues

Postby Janina Baltaziewicz » Fri Jun 02, 2017 12:23 pm

Hi everyone,

Just a short note:
It is not a bug that WD V6 doesn't bypass the firewall anymore, it is by design. Reason for that is very simple: security. A program bypassing your very own computer security system, i.e. the firewall, can pose a great danger. Especially with the WD now based on a whole new concept.
We do have in mind that this is not practical for every user, so we are already discussing and checking other options.

Cheers!

Janina
Janina Baltaziewicz
Technical Support Technologist
User avatar
Janina Baltaziewicz
 
Posts: 36
Joined: Tue Jun 14, 2016 2:08 pm


Return to Widget Designer V6

Who is online

Users browsing this forum: No registered users and 1 guest

cron