Textbox Append with Quotes issue

Christie Widget Designer Version 6 - Q&A

Moderator: Moderator Group

Forum rules
When asking make sure to include the operating system and the revision of Widget Designer you are using.

Textbox Append with Quotes issue

Postby chrisr » Tue Jun 06, 2017 2:44 pm

Good morning,
I have a quick question on TextboxAppend. If I want to append "BLKVID -m 1[CR][LF]") quotes included. I end up with a string that doesnt work.

WDTextboxAppend(1,""BLKVID -m[CR][LF]")")

obviously that tosses a bunch of errors in the debug logger. Is there a way around this, that i can still have quotes appended to the textbox?

Ultimately I'd like to Execute a script in the textbox that is TCPSend(1,"BLKVID -m[CR][LF]")

I've tried this string, got it to place text, but minus the qutoes

WDTextboxAppend(1,("BLKVID -m[CR][LF]"))

Thanks for any insite!
Thank You

ChrisR
SurfacePro3 - 2GHz i5 - 4GB ram - Windows 10 Pro - WD Pro 4.7 Rev2500 and WD 6 Rev4242_RC
Sager Laptop - Intel 2.4GHz i7 3630QM - 16GB ram - Windows 7 Pro Svc Pack1 - Offline Manager V5.1_Rev13378 & V6_Rev14607
chrisr
 
Posts: 98
Joined: Tue Jan 26, 2016 10:50 pm

Re: Textbox Append with Quotes issue

Postby chrisr » Tue Jun 06, 2017 4:02 pm

FIGURED IT OUT, Thanks for reading.

And this is it:

WDTextboxAppend(1,'"Hello World"')

Single Quotes followed by Double quotes.

http://www.coolux.de/root/downloads/sup ... les_wd.htm

Read under String, is what gave me the idea to try it.

If you want to use quotation marks as part of your string, use
the other kind for declaring the string.
Thank You

ChrisR
SurfacePro3 - 2GHz i5 - 4GB ram - Windows 10 Pro - WD Pro 4.7 Rev2500 and WD 6 Rev4242_RC
Sager Laptop - Intel 2.4GHz i7 3630QM - 16GB ram - Windows 7 Pro Svc Pack1 - Offline Manager V5.1_Rev13378 & V6_Rev14607
chrisr
 
Posts: 98
Joined: Tue Jan 26, 2016 10:50 pm


Return to Widget Designer V6

Who is online

Users browsing this forum: No registered users and 3 guests